安装

为了使用Select2,您必须在网站上包括已编译的JavaScript和CSS文件。在您的网站或应用程序中有多个选项可用于包含这些预编译的文件(也称为发行版)。

CDN使用Select2

CDN(内容交付网络)是使用Select2进行安装和运行的最快方法!

Select2托管在jsDelivrcdnjs CDN上。只需将以下代码行包含在 <head> 页面的部分:

<link href="https://cdn.jsdelivr.net/npm/select2@4.1.0-beta.1/dist/css/select2.min.css" rel="stylesheet" />
<script src="https://cdn.jsdelivr.net/npm/select2@4.1.0-beta.1/dist/js/select2.min.js"> </script>

紧随新版本发布之后,CDN会花一些时间来赶上新版本并在CDN上发布。

Bower安装

Select2在Bower上可用。将以下内容添加到您的bower.json 文件,然后运行 bower install:

"dependencies": {
  "select2": "~4.0"
}

或者,运行 bower install select2 从您的项目目录。

预编译的分发文件将在 vendor/select2/dist/css/vendor/select2/dist/js/,相对于您的项目目录。将它们包括在您的页面中:

<link href="vendor/select2/dist/css/select2.min.css" rel="stylesheet" />
<script src="vendor/select2/dist/js/select2.min.js"></script>

手动安装

我们强烈建议您使用CDN或包管理器(例如Bower或npm)。这将使您更轻松地在不同环境中部署项目,并在发布新版本时轻松更新Select2。但是,如果您希望将Select2手动集成到项目中,则可以从GitHub下载所选版本,并将文件从dist目录复制到项目中。

在页面中包含已编译的文件:

<link href="path/to/select2.min.css" rel="stylesheet" />
<script src="path/to/select2.min.js"></script>